It is currently Thu May 25, 2017 10:23 pm




Post new topic Reply to topic  [ 7 posts ] 
Mac custom keys no longer mapped and working 
Author Message

Joined: Sat Oct 09, 2010 4:47 am
Posts: 4
Post Mac custom keys no longer mapped and working
Recently I been getting errors that the keyboards drive was ejected improperly. I had icons and gif icons frozen and not responding to key strokes. I restarted everything software and hardware and still nothing works. Now it boots up the default keyboard that it comes with and won't load all the driver preference I have on my mac (snow leopard) I really feel that an internal drive or something in the keyboard is busted or something. Also I have not been using the memory chip cause it doesn't work for mac so it was never plugged in or storing anything in the SD chip. Everything was running off the driver and config.

Everything lights up as well. just not recognizing key strokes. And everything is plugged in correctly.


Sun Dec 19, 2010 3:52 pm
Profile
User avatar

Joined: Thu Mar 27, 2008 2:12 am
Posts: 235
Location: Surrey, UK.
Post Re: Mac custom keys no longer mapped and working
Firstly the SD drive is for storing keyboard critical resources and not as a port for transferring data to and from an SD card.

Secondly can you check the keyboard on another machine?


Mon Dec 20, 2010 8:47 am
Profile

Joined: Thu Dec 23, 2010 7:28 am
Posts: 1
Post Re: Mac custom keys no longer mapped and working
Hello!
I have the same problem after updating to Mac OS X 10.6.5 (10H574). The Maximus Keyboard boots normally. After some time the USB-disk MaximusDisk is automatically disconnected; Mac OS X reports an error "Disk not ejected correctly". The keyboard shows random keys lit, but no display of other Layers. My custom Layers do not work.
The keyboard layout is displayed in the MaximusDriver window. It is not transferred/updated on the board itself.
I reinstalled the Optimus Maximus Configurator and driver (Version 0.72), but no change.

The keyboard is currently not usable with my Mac!
Any support would be appreciated.
Thanks & best regards


Thu Dec 23, 2010 7:53 am
Profile

Joined: Fri Sep 05, 2008 12:42 am
Posts: 15
Post Re: Mac custom keys no longer mapped and working
I sure hope that a firmware update will be released soon to address those issues, as I am experiencing the same ones you are describing. I recall the OM behaving strangely in the past due to a Mac OS X update. Although the OM itself is discontinued, I seriously hope that support for it won't fade away. On that note, if any OM software engineers are monitoring these threads, please give us source code so other software engineers who do express an interest in the OM can keep the device functional and up-to-date with the current state of technology :)


Thu Dec 23, 2010 2:11 pm
Profile
Art Lebedev Software Developer

Joined: Wed Jul 22, 2009 7:10 pm
Posts: 9
Post Re: Mac custom keys no longer mapped and working
It looks like it sometimes happens after updating OS X to version 10.6.5. So far we don't know what
exactly leads to the problem - OS X or related EFI update, but it brings some incompatibility with the
latest versions of Maximus firmware.

The solution we found so far - is to downgrade Maximus firmware to version 0.76b. It can be done on PC,
using PC version of Maximus Configurator, or on Mac where Maximus is working, using updated Configurator
from Mac from our site (it's now shipped with firmware version 0.78b, which is renamed 0.76b).

http://www.artlebedev.com/everything/optimus/downloads/

If Maximus Configurator is not working, upgrade can be done using unix shell, please write
support@artlebedev.com for detailed instructions.


Thu Dec 23, 2010 9:22 pm
Profile

Joined: Thu Aug 13, 2009 11:48 am
Posts: 6
Post Re: Mac custom keys no longer mapped and working
Exactly how do I downgrade the firmware on my MAC?
Its confusing that you have renamed the firmware from 78 to 76.
The configurator tells me this : Firmware version Current : 0.76 Latest 0.78 - Does this mean that I have 0.76b as my current firmware?
I dont hope so - cause nothing works with my Optimus right now (Im on 10.6.6)


Fri Apr 01, 2011 10:56 am
Profile
User avatar

Joined: Thu Mar 27, 2008 2:12 am
Posts: 235
Location: Surrey, UK.
Post Re: Mac custom keys no longer mapped and working
Attachment:
Capture.JPG
Capture.JPG [ 26.9 KiB | Viewed 15554 times ]


I don't have a mac so I am not sure if the screens are different but you should see something like this.

Looking at the current list of firmwares shows that they are all followed by the letter b so you may well have the latest version.

The most important note is that you should only downgrade the firmware using a pc or mac where the software is working properly so I suggest that you try finding a friend with a PC to run the firmware upgrade on.


Fri Apr 08, 2011 5:03 am
Profile
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © phpBB Group.
Designed by Vjacheslav Trushkin for Free Forum/DivisionCore.